Students Getting "Invalid File Type" Error when Submitting to Canvas Assignment from OneDrive or Google Drive

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Issue:

When attempting to submit a file for a Canvas assignment from either MS OneDrive (Office365) or Google Drive, student gets an "Invalid submission file type" error, even though the selected file is one of the accepted file types.

Root Cause:

This error will occur if:

1. The instructor has selected the "restrict file types" checkbox in the assignment settings AND
2. The student tries to pull a file directly from OneDrive into a assignment submission (even if the file they choose is an allowed type)

This is a known issue with both LTIs. 

Resolution Details:

There is no available resolution at this time. End-users (faculty and students) should be advised to use the work-arounds suggested below. Admins: please see the information about upgrades under "Additional Information."

Environment/Applies To:

Canvas LMS

Work-a-round:

There are several possible work-arounds:

1. The instructor could choose to uncheck the "restrict file types" checkbox in assignment settings. Then students will be able to upload from Google Drive or MS OneDrive.

2. The student could download the files from OneDrive or Google Drive to their computer, then simply use the "File Upload" option

3. Students could be advised to sync their OneDrive to their computer such that they could navigate their OneDrive using the Upload file dialogue. For Windows 11 (or higher) users, this functionality may already be in place. For other users, this would need to be done in advance (not at the time that the student is attempting to submit the assignment). See the following articles for instructions: Sync files with OneDrive in Windows and Sync files with OneDrive on Mac. There is likely a similar solution for using Google Drive. 

4. The instructor could allow for submission types of "Online - Text Entry" and/or "Online - Website URL" and allow students to input a link to their file in OneDrive or Google Drive. Note that this option would not allow the instructor to be able to view, or annotate/grade the document within Canvas - they would have to click on the link to open the file (in a new tab). Furthermore, this option requires that students have set the document sharing permissions correctly. Finally, with this option, the student would still be able to make changes to the document after the submission deadline. This may be a positive or a negative, depending on the nature of the assignment.

5. Instead of selecting the "Online" submission type, the instructor could select the "External Tool" file type and then choose either Google Drive Cloud Assignment or Office365 Cloud Assignment. This would work in the case where the instructor wants to give the students a copy of a file that they have prepared (for example, a template). The students will each get their own copy, then they will submit their version (after making changes).

Additional Information:

Note for admins: as of November 2024, both LTIs are version 1.1. It is possible that upgrades to 1.3 would eliminate this issue. However, it is not possible for FSU to use Google LTI 1.3 because our institution does not have managed Google account. Regarding the OneDrive LTI, it is currently not yet clear whether an upgrade would eliminate this issue.

Details

Details

Article ID: 162943
Created
Mon 11/25/24 1:19 PM
Modified
Mon 11/25/24 1:19 PM