Google LTI: 403 Error

Issue:

Instructor is attempting to connect a file from their Google Drive using the Google Assignments LTI (Google Drive Cloud Assignments). They see a 403 Error Message: "We're sorry, but you do not have access to this page. That's all we know." This tool has worked successfully for the instructor in the past.

Root Cause:

It is possible that the connection between the user's Canvas account and their Google has been disrupted and/or that authentication needs to be reset.

Resolution Details:

Attempt the following steps, in order:

  1. Log out of Canvas and all Google accounts
  2. Clear browser cookies and cache
  3. Log back into Canvas, and try to set up the Google Cloud Assignment. For best results, start a new assignment rather than attempting to remediate an existing one. The user should be prompted to authorize Google and log into their Google account. Finish setting up the assignment.
  4. [Optional, if assignment is still not working]: delete Google from Registered Services and Approved Integrations. These can be found in User Account Settings in the Global Navigation menu (first item, with profile picture). See the following Canvas guides for more information (including screenshots) about how to locate these areas: What are Profile and User Settings? and How do I manage API access tokens [Approved Integrations] in my user account?
  5. Repeat steps 1-3

Environment/Applies To:

Canvas LMS

Additional Information:

This issue is described in the context of using the Google LTI (Google Drive Cloud Assignment) as an external tool when setting up an assignment. However, the same issue could arise when attempting to use the Google LTI in other contexts: embedding or linking from Google Drive via the Rich Content Editor, when attempting to submit to an assignment from Google Drive (students), Collaborations, or attempting to add a file from Google Drive to a Canvas Module. The resolution steps should be the same.