Issue:
In attempting to upload a file into a Canvas course, you received an error message, such as "Error: file size exceeds quota."
Root Cause:
The probable cause is that you have exceeded the 524 megabyte file storage limit available in a Canvas course shell. To confirm, click "Files" in the Canvas course menu and scroll to the bottom. You will be presented with a percentage used.
This quota is in place both to maintain lower university-wide Canvas data usage and to support equitable access, as larger courses and files can prove problematic to access for students with limited internet access or mobile devices.
Resolution Details:
In the Canvas course menu, navigate to the Files area.
- Order the list of files by "Size" so that you can identify which files are using up the most space.
- Identify files that can be removed from the course. Hover over each file and click on the three-dots to view options.
- Select "Delete" to remove unnecessary file(s) from the course.
- Verify that you are now using less than 100% of your file storage quota by navigating to the bottom of the Files area.
If you need to share large files with your students (e.g., media-rich PowerPoint files), we recommend uploading the files to a folder in Microsoft OneDrive. You can share a link to the OneDrive folder on a page in your Canvas module.
To reduce the size of Powerpoint files, try compressing images or deleting less necessary content.
If you're looking to share video, such as a recording with voiceover, we recommend Panopto or VoiceThread.
Environment/Applies To:
Canvas
Additional Information:
How do I view course files as an instructor? (Canvas Guide)
How do I delete a file or folder as an instructor? (Canvas Guide)
Please contact eto@framingham.edu to get support with file management in Canvas.